ArcView: What you need to know about ArcView and Spatial Analyst to use Arc-WofE...


References

ArcView and Spatial Analyst:

Inside ArcView GIS by Scott Hutchinson and Larry Daniel. OnWord Press, 1996, 407 pp.

Getting to Know ArcView GIS, Second Edition for Version 3.0,GeoInformation International, 1997, 675 pp.

Using the ArcView Spatial Analyst, Environmental Systems Research Institute, Inc, 1996, Redlands, CA.

Avenue:

ArcView GIS/Avenue Developer's Guide by Amir Razavi. OnWord Press, 1997.

ArcView/Avenue Programmer's Reference (Version 3), by Amir Razavi, John Alexander and Valerie Warwick. OnWord Press, 1997, 500 pp.


Loading an Extension

1. If not currently active, make the project window active:

Select the window item ‘1. <project file name>.apr’ from the Window menu.

2. Select Extensions... from the File menu. A dialog box will appear that lists all of the extensions available to load.

3. Check the box beside the extension title you want to use.

4. Click ‘OK’ to load the extension.

About Extensions

Extensions are new to ArcView starting with version 3.0. ESRI uses extensions to deliver modules that supplement ArcView’s basic functionality. ESRI also allow ArcView users to write their own extensions using ArcView’s scripting language, Avenue.

An extension is a particular type of Object Database. The objects in an extension may include Avenue scripts, new interface controls or customized document interfaces (DocGUI’s). When you load the Arc-WofE extension, the Avenue scripts that run the Arc-WofE functions are added to ArcView’s system script. The Weights of Evidence menu and tool menu are added to the View interface.

When you save a project, references to any extensions currently loaded are written to the project file. When you open that project file at a later time, ArcView will look for the references extension file (*.avx) and load it if found. If ArcView cannot find the extension file, it will ask you to specify a path to the file.

ArcView On-line Help Topic: What is an extension?

Next Section Contents Home

How to manage Grid data sets

A grid data set is stored in a directory called a workspace. Each grid data set is stored as a separate directory with associated tables and files that contain specific information about the grid. Each grid data set also stores some files in an INFO directory found in the workspace.

Do not use your computer's file system commands with grid data sets

Because each grid data set stores files in the INFO directory, you cannot rename, copy, or delete them with the computer's file management system. Rename, copy, or delete grid data sets with the Data Source Manager supplied with Spatial Analyst (or the Grid Manager in version 1.0). You can access the Manage Data Sources (or Grid Manager) dialog from the File menu when a view is active.

Note: The Data Source Manager loaded by Spatial Analyst 1.1 also allows the management of Shapefiles, so you do not have to worry about deleting all the files associated with a Shapefile, i.e., .shp, .dbf, .shx and any other index files.

ArcView On-line Help Topic: grid data sets, frequently asked questions and grid data sets, described (above text was taken directly from these help topics)

Next Section Contents Home

How to organize your data sets as Themes in a View document

Theme Inputs to Arc-WofE and their source data types:

Arc-WofE Input

Training Point Theme

Study Area Grid Theme

Evidential Theme

Spatial Data Type Vector Raster Vector or Raster
ArcView Theme Type Point Feature Theme Grid Theme Polygon Feature Theme

Integer Grid Theme

File Source Formats ArcView shapefile

ARC/INFO coverage

event theme based on table

Grid ArcView shapefile

ARC/INFO coverage

Integer Grid

Notes: Place at top of Table of Contents Place at Bottom of Table of Contents Theme’s extents do not need to be the same as the extents of the study area

 

Next Section Contents Home

How to add a data set as a Theme to a View document

1. Open or create a View document.

2. Click the ‘Add Theme’ button

OR

Select Add Theme... from the View menu.

3. In the dialog box that appears:

Select the theme type you want to add from the combo box in the bottom left corner of the dialog. If you want to add a Grid Theme and Grid Theme does not appear in the list, most likely the Spatial Analyst extension has not been loaded. Close the dialog, load Spatial Analyst, then resume adding your themes.

Navigate to the location of your data set(s). Select the data set(s) you want to load and click ‘OK’. You can load more than one data set at a time by holding down the shift key and clicking the names of the data sets you want to add to the selection set, then click ‘OK’

Note: If have added Grid Themes to the view but Arc-WofE does not seem to be recognizing them and Spatial Analyst’s menu items are, or mostly are, disabled, you have probably added a grid data set as an Image theme. You can check this by making the theme active, then selecting Properties... from the Theme menu.

ArcView On-Line Help Topic: themes, adding

Next Section Contents Home

How to convert your data sets to formats that ArcView and Spatial Analyst can use

Image Theme to Grid Theme conversion

This method can be used to convert raster data sets in formats other than ESRI’s grid format to grids. ArcView supports the following formats as Image Themes:

TIFF; TIFF/LZW compressed; ERDAS; IMAGINE (if ArcView’s IMAGINE image extension is loaded); BSQ, BIL and BIP; Sun rasterfiles; BMP; Run-length compressed files; JPEG (if ArcView’s JPEG image extension is loaded); Image catalogs;

The following is a sample contents of a header file that ArcView requires in order to read a BIL file:

NROWS 813
NCOLS 1302
NBANDS 1
NBITS 8
BYTEORDER M
ULXMAP 537529.48752835
ULYMAP 5031945.62548415
XDIM 94.9999865
YDIM 94.9999865

To load a raster format as an Image Theme:

Load a Theme to the View, as described in the preceding section, selecting ‘Image Theme’ from the Data Source Types: combo-box.

To convert your Image Theme to a Grid Theme:

1. Make the image theme active.

2. Set ‘Convert to Grid’ from the Theme menu.

Once you have converted the Image theme to a Grid Theme, you can delete the Image Theme from the View.


Analysis Reclassify...

Use the reclassify function to reclassify a Grid Theme. Reclassify operates on the active Grid Theme(s) and creates new grids which you can add to the current View as themes.

You could use Reclassify to:

Map grid cell values to new values.

Map ‘No Data’ to a value or map one or more values to ‘No Data’. ‘No Data’ can be thought of as Null and corresponds to -9999 in ARC/INFO.

Reclassify can be useful to create a Study Area Grid Theme.

ArcView On-Line Help Topic: Reclassifying


Selecting a subset of features or classes to create a new data set

For both a Feature Theme and an integer Grid Theme, you can select features or cells with defined values by querying the theme’s attribute table.

1. Make the theme you want to subset active by clicking on its legend in the table of contents.

2. Click the Query Builder button .

3. Build your query by selecting fields, operators and values from the lists on the dialog. Then click ‘OK’.

4. You can create a new data set from your selection selecting either:

a. Convert to Shapefile...

OR

b. Convert to grid...

from the Theme menu.

Next Section Contents Home

Query Builder Dialog

The Query Builder Dialog, an ArcView Dialog accessible by Avenue, is used several times by Arc-WofE to allow you to define subsets of features or cells. It can be run from the following dialog boxes/functions:

Set Parameters Dialog: Select a subset of training points by attributes

Generalizing an Evidential Theme, Grouping Dialog: Select a group of records in the evidential theme’s attribute table to map to a new class.

Extract Contacts: Define two sets of polygons from which you want to extract contacts.

Also, prior to using the Buffer Features... function, you may want to select a subset of features or classes to buffer.

ArcView On-Line Help Topic: Query Builder (Dialog Box)

Next Section Contents Home

Document Names

Arc-WofE uses ArcView document and theme names almost exclusively in processing. If more than one document or theme name are identical, ArcView won't be able to distinguish them and may try to use the wrong one. Please refer to 'What you need to know about ArcView and Spatial Analyst'.

How to change the name of a Theme or Document

To change the name of a document:

Open the document.

Select the Properties... item from the menu with the document name.

Edit the document name in the Properties dialog and click 'OK'.

To change the name of a theme:

Activate the View that contains the theme.

Select the Properties... item from the Theme menu.

Edit the theme name in the Properties dialog and click 'OK'.

Next Section Contents Home

You can export an ArcView table document or a selection set of a table document to one of the three data base formats that ArcView supports: dBase, INFO and comma-delimited text.

To export a table:

Open the document you want to export.

Select Export... from the File menu in the Table GUI.

Select the file format you want to export to, provide a file name and click 'OK'.

What happens to the field names when I export part or all of a table document?

The Table.Export script that ArcView runs from the File–>Export... item, exports the field name aliases. If you are exporting to dBase format, the field name for the W+ field will be W_ and the field name for the #Points field will be ZPoints. This appears to be a problem only with the dBase format: the INFO and delimited text formats handles the aliases well.

Arc-WofE adds a function in the Table GUI File menu labeled 'Export With Names...'. Use this function if you want to preserve the dBase compatible names used in tables created by the extension.

ArcView on-line Help Topic: Exporting, a table

Section Contents Home